Home Forums HAast (High Availability for Asterisk) Configuration & Optimization Run result 3 when starting FreePBX on old hardware

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • Avatar photoCustomer Inquiry
    Post count: 201

    I’m running FreePBX on a couple of old servers for testing. I installed HAAst and although everything seems to work, I sometimes see this error after failing over the cluster:

    Sat Jun 23 23:02:23 2018, 00000721, E, System Command, Failed to start Asterisk (start) wrapper. Run result 3; exitcode 0

    What is wrong?

    Avatar photoTelium Support Group
    Post count: 262

    Run result 3 means that it is taking too long to start Asterisk/FreePBX and something is wrong, so HAAst gives up.

    In your case there are two compounding factors. First the old hardware is probably slowing started, but to an acceptable level. Second, FreePBX’s startup script can be very slow as it resets permissions on lots files, etc. If you start the FreePBX service manually you will even see a warning message about slow startup (and a link to their wiki on how to speed it up).

    Your choices are to speedup the FreePBX start (as outlined by Sangoma on their website), or, increase the amount of time HAAst will wait. To properly solve the problem try to start the FreePBX service directly (with the HAast service disabled). Check for errors onscreen or in the log, and confirm how long it takes for FreePBX to start.

    If you really can’t solve the reason for slow FreePBX start, then edit the maxstarttime (in haast.conf) to allow for a slower start. Note that if the error occurs on failover only (HAast already running) the promotesnoozetime is also available – but check with Telium support before you play with these values.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.