Home Forums SecAst (Security for Asterisk) Installation & Upgrade Can’t find Qt prerequisite package

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Customer InquiryCustomer Inquiry
    Participant
    Post count: 182

    The Linux distro I’m using only offers Qt version 5.3 as a package, but I see your software needs Qt version 5.5 or later. How do I install that prerequisite? I’ve searched every repo and no one has the Qt framework prebuilt for my Linux Distro.

    Telium Support GroupTelium Support Group
    Moderator
    Post count: 242

    Most Linux distributions are starting to include Qt version 5.7 (as of December 2016) so check available repos (including testing repos) first to ensure it’s not there. If you can find Qt version 5.5 or later as a package it’s best to install from your package manager. Otherwise continue on below.

    If you are running Ubuntu you can check this link for a step-by-step guide to installing Qt 5.x: http://sourcedigit.com/19858-how-to-install-qt-5-6-1-on-ubuntu-16-04/

    If your system runs headless (i.e. no graphical shell) then you can also modify the Qt installer to run without its GUI as described here:
    http://stackoverflow.com/questions/25105269/silent-install-qt-run-installer-on-ubuntu-server

    If the above suggestions don’t work, then we recommend you download ‘Qt Creator’ directly from http://www.qt.io This package is overkill, but it does an excellent job of installing everything you need (and more) relating to Qt.

    After that you should have Qt 5.7 or later installed, including other Qt dependencies listed in the installation guide.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.